Major ImpactLast updated: Fetched just now
Issues with network performance in North America
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Updated
We are continuing to monitor for any further issues.
- Updated
We are continuing to monitor for any further issues.
- Updated
We are continuing to monitor for any further issues.
- Monitoring
A fix has been implemented and we are monitoring the results.
- Identified
Cloudflare has identified issues with network performance in North America. We are working to analyse and mitigate this problem.