Minor ImpactLast updated: Fetched just now
New members invitations to accounts not being sent
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Monitoring
A fix has been implemented and we are monitoring the results.
- Investigating
Cloudflare is investigating issues with invites for new members of accounts that are not being sent to the invitees, impacting their ability to join organizations. We are working to mitigate this problem. More updates to follow shortly.